Browse Site by Tags

Showing related tags and posts accross the entire site.
  • Compatibility question...

    I'm eligible to upgrade from Xpress Pro to MC3 but am not sure that my CPU will accommodate--I read the "requirements" but saw some comments in the posts that say I may potentially work with the system below. I already know that since I'm at 10.4.11 I have to upgrade my OS, right? But...
    Posted to Avid Media Composer - Mac (Forum) by tastyframe on Sun, Apr 26 2009
Page 1 of 1 (1 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller