Browse Site by Tags

Showing related tags and posts accross the entire site.
  • Avid Media Composer 8.1.0.3 Interface Unresponsive

    Hello Community, I am having an issue with my Avid Media Composer 8 interface. I orginally had issues installing the programs which Avids Tech Support ended up fixing the problem which took over 2 months. When it finally was able to open I had problems with the interface. When I tried to click the menu...
    Posted to Avid Media Composer - PC (Forum) by carterxian on Fri, Nov 14 2014
  • Background service Failing

    I installed Avid 8.2 coming from 7.0 When I try to background render or trascode the service is always off and the arrows are red with a service failure! I reinstalled 3 times Avid but it doesn't work! The DMF service give the same problems I read that's a known issue but I still haven't...
    Posted to Avid Media Composer - PC (Forum) by daniele on Wed, Oct 29 2014
  • Media Composer 5 Maxiumum Allowed Activations

    A few months ago my computer had a system error and deleted some files off my computer, after this my AVID MC would no longer open claiming that I was not registered. I unistalled the program and reinstalled but now when I try to open it claims my serial number has reached its maximum number of activations...
    Posted to Avid Media Composer - PC (Forum) by JonesyZone on Thu, Jan 12 2012
  • Error with the program. Please help me!

    I downloaded the trial version for my windows xp computer because I wanted to test out the program before buying it. Whenever I open it I get a message saying: And then I click continue and the program runs like its supposed to for like 5 seconds and then it closes automatically. I've tried opening...
    Posted to Avid Media Composer - PC (Forum) by katelynn556 on Mon, Jul 26 2010
  • Neophyte needs help

    I am as new to Media Composer as you can get and need some help getting things up and running. I downloaded the MC 4.5 trial and installed uitto make sure the application would work on my system. It didn't like my video card but ran otherwise. I have since changed to a Quadro FX 1700. When the trial...
    Posted to Avid Media Composer - PC (Forum) by johngilkey on Thu, Jul 8 2010
  • Re: Installing Media Composer on Vista Home Premium

    "Avid Editor has stopped working." Please pass on to others within this blog... I was sick when I saw this message on my machine... I tried everything, uninstalling, re-installing, turning off anitvirus, re-booting in safe mode... I basically rant the gamit... For some reason, I tried to open...
    Posted to Avid Media Composer - PC (Forum) by David R. Gustafson on Tue, Apr 13 2010
Page 1 of 1 (6 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller