Browse Forum Posts by Tags

Showing related tags and posts for the Avid Media Composer - Mac forum. See all tags in the site
  • Help! MC5 Activation Failing

    Hello! We have two situations here: 1. MC5 Academic - activated, been running for months but now fails to transfer activation (from Windows workstation to iMac). Windows machine got deactivated and confirmed properly but iMac fails to activate even on the next day. Now, it fails to authorize back to... (read more)
    Posted to Avid Media Composer - Mac (Forum) by Ervz Tia (Tikboy) on Tue, Jun 14 2011
  • Update problems MC 3.0 academic > MC 3.1.2

    Hi everyone, I just updated my academic version of media composer from 3.0 to 3.1.2. Now, whenever i start avid, the loading screen still says "Media Composer v3.0", then when it finnishes the loading process, I get the message that Media Composer quit unexpededly. Any solutions / similar situations... (read more)
    Posted to Avid Media Composer - Mac (Forum) by b_calhoun on Sat, Mar 28 2009
  • MC 3 Academic Upgrade

    I just downloaded the MC 3 upgrade for $295 and went to upgrade my system. After putting in my Sys ID and Serial Number and upgrade key, I got the updater file. When I run the update it says there isn't a compatible dongle found on the system with the dongle plugged in. I tried re-installing the... (read more)
    Posted to Avid Media Composer - Mac (Forum) by cm329204 on Wed, Jun 11 2008
Page 1 of 1 (3 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller