Latest post Thu, Apr 3 2014 8:29 PM by Charles-Etienne Viau. 30 replies.
Page 3 of 3 (31 items) < Previous 1 2 3
Sort Posts: Previous Next
  • Thu, Apr 3 2014 8:29 PM In reply to

    Re: Got a Dongle Problem?

    I have the same issue as this post talk about, i have a dongle rainbow duo that i need to upgrade and i've been told that the version is not compatible for upgrade cause the Rainbow Duo is too old, i need a Rainbow SuperPro.

    Can u help me ?

Page 3 of 3 (31 items) < Previous 1 2 3

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller