Latest post Thu, Mar 12 2015 1:14 PM by usatraveler. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • Wed, Mar 11 2015 3:57 PM

    • JRLON
    • Not Ranked
    • Joined on Wed, Mar 11 2015
    • Posts 2
    • Points 30

    AVID XPRESS PRO 5.7.2 INSTALLATION PROBLEMS MAC

    Hi,

    I have a big mess on my hands and wonder if anyone can help. Years ago I bought AVID XPRESS PRO V 5.7.2 (both Mac and PC) and then years later, following a promoted offer from AVID, I bought an upgrade to Media Composer 5. 

    AVID XPRESS PRO V 5.7.2 for MAC at this time had an issue and it was recommended that users download an updated version from the internet rather than install using the DVD. But since I had a PC not Mac at this time I didn't bother downloading the updated version.

    Now I have a Mac but it is now way past time to download the updated version from the internet. 

    My mac is a MacBook Pro 13-inch, Mid 2012

    Processor  2.5 GHz Intel Core i5

    Memory  4 GB 1600 MHz DDR3

    Graphics  Intel HD Graphics 4000 1024 MB

    Software  OS X 10.9.5 (13F34)

    I've tried installing the software using the DVD supplied, and the registered dongle. It didn't install correctly. Some files are missing/corrupt namely the following:

    system/library/extensions/ATTOExpressPC14.kext ///ATTOExpressRAID_Enabler.kext ///ATTORAID_OS10.kext ///Avid_SCSI.kext ///Avid_SCSI_RBC.kext ///DigidesignFireWireAudio.kext ///DigidesignMbox2.kext ///DigidesignMbox2Boot.kext ///DigilO.kext ///Sentinel.kext

    which throw up constant annoying messages.

    On top of this my dongle isn't recognised even though it was registered with AVID at the time. And so I can't open AVID Xpress Pro 5. I also cannot seem to uninstall the software. 

    To install the upgrade to MC 5, I have to update the dongle. My mac refuses to allow me to use the Dongle Updater. (administrative issues-allegedly-even though I have full admin rights on my own Mac)

    Questions. Is it the case that my software just will never work with my Mac because the OS is too advanced? If it should work how should I proceed?

    Do I need to re-register my dongle with my new system? How do I do this? Do I need to register it for use with Xpress Pro 5 first and then update it to MC5? or can I cut to the chase and just update/register for MC5? Can I do this online since my updater isn't working? Does it matter that my previous installation is messed up (I'm guessing that it does)  eg. could I just update the dongle for use with MC5 and then install MC5 and hope for the best?

    I have tried to purchase a one-time Avid Support Code to obtain support via telephone, but this was also a big disaster with the code not coming through and then seemingly having been used previously when I did eventually locate it. Yet another big waste of time and money.

    Would appreciate an honest opinion. Thanks.

  • Wed, Mar 11 2015 4:19 PM In reply to

    Re: AVID XPRESS PRO 5.7.2 INSTALLATION PROBLEMS MAC

    The final qualified OS for Xpress Pro 5.7.2 was 10.4.9 (XP 5.8.3 was qualified for OS 10.4.11).

    Xpress Pro Version Matrix

    The final qualified OS for Media Composer 5.0.4 was 10.6.7.

    Media Composer Version Matrix - see the "Legacy MC Version Matrix"

    Therefore, your versions of the software most likely won't work well at all with the much-newer OS and system, unfortunately.

    For the dongle, I'm not sure why it's not being seen.  Perhaps someone else can chime in there.

    Media Composer 8 is now available - and upgrades have been re-introduced for a limited time.  Owners of any version of MC, including 5, can upgrade to MC8 and get a full year of standard support as well as any upgrades that may be released within that year.  If you think it might be the right option for you, take a look:

    Avid Store - Media Composer Upgrades

    Keep in mind that if you're not sure yet, you can install MC8 and run it in trial mode for 30 days.

    (SYSTEM 1) iMac Late 2012 27" (13,2), Mac OS X 10.12.6, Avid Media Composer 2018.10 w/Symphony, Intel Core i7 3.4 GHz, 32 GB RAM, NVIDIA GeForce GTX... [view my complete system specs]
  • Thu, Mar 12 2015 12:50 PM In reply to

    • JRLON
    • Not Ranked
    • Joined on Wed, Mar 11 2015
    • Posts 2
    • Points 30

    Re: AVID XPRESS PRO 5.7.2 INSTALLATION PROBLEMS MAC

    Thanks very much. Makes sense. I will look into the AVID 8 upgrade and take it from there. 

    I just have one question. To install an upgrade, do the other versions need to be installed first? or do you just install the latest version and update the dongle registration? Thanks.

  • Thu, Mar 12 2015 1:14 PM In reply to

    Re: AVID XPRESS PRO 5.7.2 INSTALLATION PROBLEMS MAC

    Absolutely uninstall any and all previous versions.

    (SYSTEM 1) iMac Late 2012 27" (13,2), Mac OS X 10.12.6, Avid Media Composer 2018.10 w/Symphony, Intel Core i7 3.4 GHz, 32 GB RAM, NVIDIA GeForce GTX... [view my complete system specs]
Page 1 of 1 (4 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller