Latest post Sat, Mar 29 2008 5:11 PM by janusz. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • Tue, Oct 9 2007 7:17 PM

    • janusz
    • Top 500 Contributor
    • Joined on Thu, Oct 13 2005
    • Paris
    • Posts 394
    • Points 4,570

    Paint effects not properly scaled from SD 16/9 to HD + Fluidmotion pb

    I've some DNxHD 185X footage to which I'm applying a 50% fluid-motion slowdown.
    There are some artefacts as to be expected which I can correct by altering the motion vectors manually.

    However:
      i) Editing the motion vectors on the HD footage is very slow, so I make use of the RT downconvert feature of the Mojo by changing the project type to PAL/25i.  The previewed effect result corresponds to the HD version at first glance.
    However if I launch the Fluidmotion editor and look at the objects I created to correct the motion vectors, they have been squashed vertically in going from HD-SD and get stretched vertically when I change the project type from HD to SD - meaning I cannot establish my corrections in SD (much quicker) before switching to HD  - objects don't maintain their aspect ratio when switching project types.
    This seems to be a bug.  My monitors stay in 16/9 as to be expected.

     ii) In my footage, an object (on a black background) falls of the screen in the bottom left.  As would be expected, the motion vectors are wrong in the last few frames as the object is no longer on screen.  Replacing the motion vectors with a vector pointing south-west should solve the problem.  It does... sort of.....   The image is fine except of the fact that there are borders in the bottom and left-hand edges of the frame that are much brighter, where the set-vector object is placed.   The width and height of these luminous borders are proportional to the x and y magnitudes of the set vector object.  This seems to be the case whenever a SW vector is placed in the bottom left of the screen.

    Any ideas anyone?

    janusz

    MC 2.7.2/G5 2G bipro/Mojo SDI

    MC 2018.12 / OS 10.12.6 + others elsewhere [view my complete system specs]
  • Fri, Mar 21 2008 11:23 AM In reply to

    • janusz
    • Top 500 Contributor
    • Joined on Thu, Oct 13 2005
    • Paris
    • Posts 394
    • Points 4,570

    Paint effects not properly scaled from SD 16/9 to HD

    Working on a documentary shot in DVCPRO HD 1080/25PsF, project is 1080i/50 switched to PAL 25i to take advantage of the RT downconvert of the Mojo for the client monitor, and speed up certain preview renders in SD.

    Paint effects do not properly scale when switching projects and making the effect unrendered.  It seems to be that MC erroneously does not take into account the fact that HD projects become 16/9 SD projects (and not 4/3) : paint effects are stretched vertically when the project is converted back from SD to HD.

    This is an annoying bug - anyone have any workarounds?

    It seems to concern all paint-type effects, the paint effect itself, not only manual modification of Fluidmotion vectors with the paint tool as in (i) in my previous post

    Janusz

     

    --

    MC 2.7.2 with Mojo SDI / G5 2Ghz bipro

    MC 2018.12 / OS 10.12.6 + others elsewhere [view my complete system specs]
  • Sat, Mar 29 2008 5:11 PM In reply to

    • janusz
    • Top 500 Contributor
    • Joined on Thu, Oct 13 2005
    • Paris
    • Posts 394
    • Points 4,570

    Re: Paint effects not properly scaled from SD 16/9 to HD

    bump

    MC 2018.12 / OS 10.12.6 + others elsewhere [view my complete system specs]
Page 1 of 1 (3 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller