Latest post Sun, Apr 7 2019 7:11 PM by Danny Kotz. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • Tue, Apr 2 2019 6:38 PM

    • Danny Kotz
    • Not Ranked
    • Joined on Thu, Oct 4 2018
    • Berlin
    • Posts 2
    • Points 20

    Media Composer for Yosemite 10.10.5

    Hi

    I would like to download Media Composer First so I can start learning the program.

    My MacBook pro is from 2011 and my operating system is Yosemite 10.10.5.

    I read in the forum that the supported version of Medica composer is 8.4.1

     

    I can't find anywhere to download this version. what should I do in this case or is there any other free version I Can start with for this operation system?

     

    Thanks in advance!

    Danny

    Macbook Pro Yosemite 10.10.5 [view my complete system specs]
  • Wed, Apr 3 2019 10:55 AM In reply to

    • Pixel Monkey
    • Top 75 Contributor
    • Joined on Thu, Oct 13 2005
    • Everywhere. Just like Avid ;)
    • Posts 1,247
    • Points 15,780
    • Moderator: Broadcast Newsroom
      Moderator: Media Composer Getting Started

    Re: Media Composer for Yosemite 10.10.5

    Hi Danny, and welcome. The folks here in this Getting Started Fast forum can certainly help you. Also go here [LINK] to a similar forum that is catered specifically to Media Composer First users. You'll find a lot of sticky-links and important FAQ at the top of that one.

    As far as Yosemite is concerned, here is a direct download link for MC|First v8.9.2: [LINK]. You'll first need to make sure all previous versions of MC|First and Media Composer (if any) are deactivated and uninstalled. If that link doesn't work, let me know. 

    Side note: The reason why Yosemite has fallen off of the approval list is due to high-end performance needs of professional editors, plus Apple has ended support for it. (So in general it is getting less and less safe to use both Yosemite and El Capitan on the internet. But understand that it is still entirely possible to download, install and run the latest MC|First onto your Yosemite machine. Just expect it to behave a little choppy in some playback scenarios. 

    ACA Leader__Avid Pro Vid Moderator__Specs? Many. All qualified. But I still do stupid things. :) [view my complete system specs]

    Editors are superheroes, cutting life together in a world that cuts itself apart.

     

    Chris Bove' (Pixel Monkey)

    Twitter: Follow @heybove

    Blog for Craft Editors

    WWLD (What Would Larry Do?)
    WWND (What Would Norman Do?)

  • Wed, Apr 3 2019 2:25 PM In reply to

    • Marianna
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Avid
    • Posts 10,615
    • Points 223,270
    • Avid Beta Moderators
      Avid Customer Advocate
      Avid Developer Moderator
      BlogAuthor
      SystemAdministrator

    Re: Media Composer for Yosemite 10.10.5

    Danny

    Chris is spot on.... for example we removed 10.12.5 and earlier from our approved OS list due to that evry reason so anyone wanting to use the newer versions 2018.x and higher needs to update their OS to 10.12.6 and higher.

    Let us know if you need any help

    Marianna

    Director of Online Communities and Forums/Customer Advocate [view my complete system specs]

    marianna.montague@avid.com

    mobile 813-493-6800

    Twitter:  avidmarianna

    Facebook: Marianna Montague

    www.avidcustomerassociation.com   |  Connect 2019 | April 6-7 | Aria, Las Vegas, NV

    WWLD

  • Sun, Apr 7 2019 7:11 PM In reply to

    • Danny Kotz
    • Not Ranked
    • Joined on Thu, Oct 4 2018
    • Berlin
    • Posts 2
    • Points 20

    Re: Media Composer for Yosemite 10.10.5

    Hey Marian,

     

    Alright I understand. 

     

    The reason I am still using Yosemite is that I have an early 2011 Macbook pro which with a hardware update works very good for me. 

     

    Aside from video editing, I am using it as well for music production and because I have the software I am using on it I cannot update the operating system. If I would update tough I would have to update all the software that I have and I rather avoid that since its all working good for me.

    I did manage to install the MC version from Chris's link, but for some reason when I try to open it I get an error message and it doesn't work.

     

    Is there a way to still make it work on my system?

     

    Thank you so much 

    Danny

     

     

    Macbook Pro Yosemite 10.10.5 [view my complete system specs]
Page 1 of 1 (4 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller