Latest post Mon, Dec 1 2014 5:31 PM by BLKDOG. 20 replies.
Page 1 of 2 (21 items) 1 2 Next >
Sort Posts: Previous Next
  • Sun, Nov 30 2014 11:14 PM

    • Marc_89
    • Not Ranked
    • Joined on Thu, Aug 4 2011
    • Posts 130
    • Points 1,750

    MC 8.2 Segmentation Fault when using "moncon off"

    Hello...

     

    Recently the "moncon off" command turned useless for me, as everytime I typed into the console, MC would crash with a "segmentation fault".

    I weren't able to use it since then.

    My latest headache with 8.2 was, that after those segmentation faults in combination with the "moncon off" command turned up, MC didn't even wanted to start. It would creash on startup and even the Application Manager was extremely laggy.

    The system is 10.9.5 and was installed only a few days ago.

    As I also weren't able to uninstall MC properly, I deleted my whole system and started fresh.

     

    Unfortunately I can't downgrade to 10.9.4 as I do not have the installer for that OS.

    MC seems to work now, but I can still not use "moncon off" as the segmentation fault was back from the start.

    I now fear that MC will be useless again soon...

    Did anyone have this problem? Is there a way to fix it? How can I get "moncon off" back to work?

     

    (and if anyone has a hint how to get 10.9.4 back it is appretiated)

     

    http://abload.de/image.php?img=screenshot2014-11-30anrjuy.png

    *Media Composer Academic 8.2.0* on a Mac with OSX 10.9.5.* iMac late 2013 Intel Core i7 quad 3,5Ghz, 24Gb RAM, Nvidia GTX780M, Thunderbolt, USB 3.0 [view my complete system specs]
  • Sun, Nov 30 2014 11:22 PM In reply to

    • BLKDOG
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Lansing, MI
    • Posts 17,731
    • Points 226,380
    • Avid Employee
      Moderator: MCA Mac
      Moderator: MCA PC

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    Go into your Mac's network settings, create a location and call it Avid. Now delete all of the NIC config settings except for the one that is feeding your storage. See if that gets rid of the Seg Fault errors. 

    Project Manager, Avid Professional Services - Americas [view my complete system specs]

    In agreement, Unity. In Disagreement, Discussion. In all things, Charity.


  • Sun, Nov 30 2014 11:41 PM In reply to

    • Marc_89
    • Not Ranked
    • Joined on Thu, Aug 4 2011
    • Posts 130
    • Points 1,750

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    I am currently y not at my workplace and will be back in about five hours and will try that. 

    In the meantime... I did not quite understand how the procedure is working ...

    i know my Mac's network settings, where I manage my wifi connections and such. But everything after that I did not quite follow. Could you please explain a bit more detailed what to do with the NIC settings (what are those?) and how could they feed my storage? 

    The sorage I am editing on is a thunderbolt drive and not a NAS.

    You see I am rather clueless what to do.

    Thank you very much for your patience :)

    *Media Composer Academic 8.2.0* on a Mac with OSX 10.9.5.* iMac late 2013 Intel Core i7 quad 3,5Ghz, 24Gb RAM, Nvidia GTX780M, Thunderbolt, USB 3.0 [view my complete system specs]
  • Sun, Nov 30 2014 11:45 PM In reply to

    • BLKDOG
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Lansing, MI
    • Posts 17,731
    • Points 226,380
    • Avid Employee
      Moderator: MCA Mac
      Moderator: MCA PC

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    Just delete everything in that window except for the thunderbolt connection. (Wireless too for the moment). This has shown to eliminate that error in a networked config. I'm interested to see if it could help you too. 

    Project Manager, Avid Professional Services - Americas [view my complete system specs]

    In agreement, Unity. In Disagreement, Discussion. In all things, Charity.


  • Mon, Dec 1 2014 10:43 AM In reply to

    • mrtrees
    • Top 500 Contributor
    • Joined on Tue, Aug 8 2006
    • London
    • Posts 313
    • Points 4,240

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    For what its worth we are seeing Segmentation faults upto five times a day in some of our suites, wether using moncon off or not.

     

    In fact we are finding MC 8.2 terrible to work with full stop

    MC 2018.7.1/OSX 10.13.5/AJA IO4K/Nexis Client 7.10/ISIS server 4.7.11 Mac Pro 3GHZ 8 Core Intel Xon E5/32GB ISIS 5000 sys director/ 2 x 32 TB expansion... [view my complete system specs]
  • Mon, Dec 1 2014 11:59 AM In reply to

    • Marc_89
    • Not Ranked
    • Joined on Thu, Aug 4 2011
    • Posts 130
    • Points 1,750

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    Hello BLKDOG,

     

    I hope I understood correctly and recreated what you described.

    This is how I changed my Network settings:

    Unfortunately nothing changed and MC still crashes immediately when using the console command.

     

     

    mrtrees,

    it sucks hearing that... but at least I am not alone. I heard a few bad things about 8.2 but never that the moncon command was renderd useless completely...

    I just need a method to go back to 10.9.4 now to downgrade to 8.1 I guess... 

    *Media Composer Academic 8.2.0* on a Mac with OSX 10.9.5.* iMac late 2013 Intel Core i7 quad 3,5Ghz, 24Gb RAM, Nvidia GTX780M, Thunderbolt, USB 3.0 [view my complete system specs]
  • Mon, Dec 1 2014 12:18 PM In reply to

    • BLKDOG
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Lansing, MI
    • Posts 17,731
    • Points 226,380
    • Avid Employee
      Moderator: MCA Mac
      Moderator: MCA PC

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    Okay but that's not exactly what I meant. Your location is still automatic. You need to create a new location, call that avid, and then have only the thunderbolt bridge NIC setting in that location. I also noticed that your thunderbolt is not connected what happens when the storage is actually online?

     

    BTW, anyone running media composer version 8.2 on a Mac should always pair down their  NICsettings to defeat the segmentation fault errors.

    Project Manager, Avid Professional Services - Americas [view my complete system specs]

    In agreement, Unity. In Disagreement, Discussion. In all things, Charity.


  • Mon, Dec 1 2014 12:29 PM In reply to

    • Marc_89
    • Not Ranked
    • Joined on Thu, Aug 4 2011
    • Posts 130
    • Points 1,750

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    This Thunderbolt Bridge setting is, I believe, in case I connect Ethernet via the Thunderbolt port...

    My Thundervolt Conection for my storage was never listed there. The storage is connected and running, all media is online in MC.

    I created a new location and called it Avid, deleted everything except the Thunderbolt.

    The segmentation when using the console unfortunately remains...

    *Media Composer Academic 8.2.0* on a Mac with OSX 10.9.5.* iMac late 2013 Intel Core i7 quad 3,5Ghz, 24Gb RAM, Nvidia GTX780M, Thunderbolt, USB 3.0 [view my complete system specs]
  • Mon, Dec 1 2014 12:35 PM In reply to

    • BLKDOG
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Lansing, MI
    • Posts 17,731
    • Points 226,380
    • Avid Employee
      Moderator: MCA Mac
      Moderator: MCA PC

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    I'm sorry I'm not understanding. Above you said that your storage was connected via thunderbolt. However this setting shows me that the thunderbolt is not connected at all. Are you saying now that you have network (ethernet) connected storage?

    Project Manager, Avid Professional Services - Americas [view my complete system specs]

    In agreement, Unity. In Disagreement, Discussion. In all things, Charity.


  • Mon, Dec 1 2014 12:47 PM In reply to

    • Marc_89
    • Not Ranked
    • Joined on Thu, Aug 4 2011
    • Posts 130
    • Points 1,750

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    Yes. I have a HDD with a Thunderbolt controller connected to the Mac via a Thunderbolt Cable. Everything us up nd running. This "Thunderbolt Bridge" interface in the network settings on the other hand had always listed "not connected". I believe it does not represent the Thunderbolt cable connection but something else...

    This screenshot is from the System Report

    *Media Composer Academic 8.2.0* on a Mac with OSX 10.9.5.* iMac late 2013 Intel Core i7 quad 3,5Ghz, 24Gb RAM, Nvidia GTX780M, Thunderbolt, USB 3.0 [view my complete system specs]
  • Mon, Dec 1 2014 1:02 PM In reply to

    • BLKDOG
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Lansing, MI
    • Posts 17,731
    • Points 226,380
    • Avid Employee
      Moderator: MCA Mac
      Moderator: MCA PC

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    Okay then that may not have any bearing on your problem. A segmentation fault error is always a problem with the connection between the storage and your media composer. We need to troubleshoot that path to see if we can get those to stop.

    do you have any other connected storage or background service running?

    Project Manager, Avid Professional Services - Americas [view my complete system specs]

    In agreement, Unity. In Disagreement, Discussion. In all things, Charity.


  • Mon, Dec 1 2014 1:09 PM In reply to

    • Marc_89
    • Not Ranked
    • Joined on Thu, Aug 4 2011
    • Posts 130
    • Points 1,750

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    Only the thunderbolt drive. Other Services running are Dropbox and Creative Cloud (and Avid Application Manager)

    I deavtivated those and tried again. Still the Seg Fault.

    The window is telling me something about "Main Thread at Adress 0x0" Maybe this is a hint?  

    UPDATE: In case something would be faulty with the thunderbolt controller and causing the seg fault, I exchanged the controller and put the HDD in a USB 3.0 Controller. Same error. 

    *Media Composer Academic 8.2.0* on a Mac with OSX 10.9.5.* iMac late 2013 Intel Core i7 quad 3,5Ghz, 24Gb RAM, Nvidia GTX780M, Thunderbolt, USB 3.0 [view my complete system specs]
  • Mon, Dec 1 2014 1:15 PM In reply to

    • BLKDOG
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Lansing, MI
    • Posts 17,731
    • Points 226,380
    • Avid Employee
      Moderator: MCA Mac
      Moderator: MCA PC

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    And if you don't run that command? What happens?

    You May need to give support a call on this one. 

    Project Manager, Avid Professional Services - Americas [view my complete system specs]

    In agreement, Unity. In Disagreement, Discussion. In all things, Charity.


  • Mon, Dec 1 2014 1:21 PM In reply to

    • Marc_89
    • Not Ranked
    • Joined on Thu, Aug 4 2011
    • Posts 130
    • Points 1,750

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    Before I made a fresh system install MC went totally unusable and wouldnt even open after a while. 

    I then was forced to make a fresh OS and MC install. Now it seems that I can edit (if I dont run that command)

    Let's see how long that lasts.

    As I am an education user I believe I am not entitled to have support calls... I think my best chance is to somehow downgrade my OS and then MC, as soon as I can bear the time for that.

    *Media Composer Academic 8.2.0* on a Mac with OSX 10.9.5.* iMac late 2013 Intel Core i7 quad 3,5Ghz, 24Gb RAM, Nvidia GTX780M, Thunderbolt, USB 3.0 [view my complete system specs]
  • Mon, Dec 1 2014 2:03 PM In reply to

    • Marianna
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Avid
    • Posts 10,667
    • Points 223,915
    • Avid Beta Moderators
      Avid Customer Advocate
      Avid Developer Moderator
      BlogAuthor
      SystemAdministrator

    Re: MC 8.2 Segmentation Fault when using "moncon off"

    Mark

    As an educational user, you should be able to contact support if ths is not your first year as in order to stay current and upgrade you would buy the $99 academic support plan which comes with support. 

    what exact CPU are you on?  Mac model and year?  I know that moncon had some issues with less than 4 cores...

    marianna

     

    Director of Online Communities and Forums/Customer Advocate [view my complete system specs]

    marianna.montague@avid.com

    mobile 813-493-6800

    Twitter:  avidmarianna

    Facebook: Marianna Montague

    www.avidcustomerassociation.com   |  Connect 2019 | April 6-7 | Aria, Las Vegas, NV

    WWLD

Page 1 of 2 (21 items) 1 2 Next >

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller