Latest post Thu, Oct 6 2016 2:09 PM by mtahir. 17 replies.
Page 1 of 2 (18 items) 1 2 Next >
Sort Posts: Previous Next
  • Mon, Apr 30 2012 8:55 PM

    • mjedit
    • Not Ranked
    • Joined on Mon, Feb 16 2009
    • Orkney
    • Posts 14
    • Points 180

    tearing fix - moncon off

    For those people who have had screen tearing problems, I can sympathise with you. My tearing happened in any video quality, both source and record, full screen, different monitors, trying different refresh rates on the monitors. I've spent days now trying to sort this. All the NVidia settings as per Avid Read Me, vertical sync on, triple buffering, tearingfix in the console command, NVidia support suggesting it might be a faulty graphics card, to running test after test, several versions of drivers, thread after thread. And then I came across this

    http://community.avid.com/forums/p/104741/606004.aspx#606004

    I typed - moncon off in the console command

    and bingo, no tearing, my footage looking how it should - elation

    Why, I don't know, as I didn't have the same problem as this was a solution for. But I'm not complaining!

    Please, can this command and a possible fix be high priority. I believe it hasn't been fixed in MC 6.01.1.

    Just to add, the image does still stutter in reverse motion, but I can live with that.

    One further thing which I've seen in a thread - I couldn't select enable video editing mode in the NVidia conrtol panel as suggested in the ReadMe file, as it was always grayed out. However, the route around this was to run control panel as administrator (even though I'm the only user, I since found out that I'm not actually administrator with FULL control).

    Hope this helps

    MC 6.0.1, Windows 7 Professional 64 Bit, MB - ASUS P6T Intel X58 Express Chipset, Processor - Intel Core i7 i7-920 2.66 GHz Quad core, RAM - Corsair DDR3... [view my complete system specs]
  • Fri, Sep 14 2012 9:45 AM In reply to

    • Chris
    • Not Ranked
    • Joined on Fri, Oct 7 2011
    • Hamburg, Germany
    • Posts 12
    • Points 150

    Re: tearing fix - moncon off

    jesus! thank u so much. i was on the same journey as u, virtually reading every single thread about this issue, trying

    every suggested solution - no avail!

    but finally this one did it on symphony 6.0.3 : aaahhh!!!  Smile

    MacPro Dual Quadcore 2.8 GHz | 16GB Ram | Nvidea Geforce GTX 285 | Lion 10.7.5 | MacBook Pro Core i7 2,8 GHz | 16GB Ram | Mountain Lion 10.8.5 | Symphony... [view my complete system specs]
  • Fri, Sep 14 2012 10:54 AM In reply to

    • Radman
    • Top 150 Contributor
    • Joined on Thu, Oct 13 2005
    • UK
    • Posts 911
    • Points 10,620

    Re: tearing fix - moncon off

    Just hope there is no MONCON OFF from above! Sure will be some tearing.

    Win10 64Bit / HP Z800-XW8200 / 5x Quadro M6000. 48 Gig Ram / Cubix Expander 4 / 2x 32TB SAS JMR Raid unit / Avid Artist | Avid Artist DNxIO. 3x 27"... [view my complete system specs]
  • Tue, Mar 19 2013 2:48 PM In reply to

    Re: tearing fix - moncon off

    Amazing!  Thank you moncon off!

    17" MBP, 2.3 GHz Intel Core i7 16 GB 1333 MHz DDR3 Mac OS X Lion 10.7.5 MC 6.0.1 [view my complete system specs]
  • Wed, Mar 20 2013 4:05 PM In reply to

    Re: tearing fix - moncon off

    Adenumn:  MONCON OFF takes care of the tearing but now my fullscreen playback turns off randomly.  Anyone aware of the initial issue being address in newer versions?

    17" MBP, 2.3 GHz Intel Core i7 16 GB 1333 MHz DDR3 Mac OS X Lion 10.7.5 MC 6.0.1 [view my complete system specs]
  • Wed, Mar 20 2013 4:51 PM In reply to

    • mjedit
    • Not Ranked
    • Joined on Mon, Feb 16 2009
    • Orkney
    • Posts 14
    • Points 180

    Re: tearing fix - moncon off

    I've not had a problem with FSP turning off randomly. Running same version MC 6.01. Sorry it didn't work out for you. It's an anomaly and not one that has been addressed as far as I can tell. 

    MC 6.0.1, Windows 7 Professional 64 Bit, MB - ASUS P6T Intel X58 Express Chipset, Processor - Intel Core i7 i7-920 2.66 GHz Quad core, RAM - Corsair DDR3... [view my complete system specs]
  • Thu, Jun 6 2013 5:16 PM In reply to

    • Nick
    • Not Ranked
    • Joined on Tue, Apr 9 2013
    • London
    • Posts 18
    • Points 180

    Re: tearing fix - moncon off

    "moncon off" didn't work with MBPr and MC 6.5. Anyone else come across a solution?

    Thanks,

    Nick

    Macbook Pro, 2.6 GHz, i7, 16GB DDR3, 500GB SSD, NVIDIA GeForce GT 650M 1024MB [view my complete system specs]
  • Thu, Jun 6 2013 5:50 PM In reply to

    • Nick
    • Not Ranked
    • Joined on Tue, Apr 9 2013
    • London
    • Posts 18
    • Points 180

    Re: tearing fix - moncon off

    Solution for MBP with Retina:

    In the "Settings" tab in Avid, go to "Full Screen Playback" and then check the "Flip on vertical Sync" Box.

    Macbook Pro, 2.6 GHz, i7, 16GB DDR3, 500GB SSD, NVIDIA GeForce GT 650M 1024MB [view my complete system specs]
  • Wed, Jul 17 2013 10:35 PM In reply to

    • cls105
    • Top 500 Contributor
    • Joined on Thu, Oct 13 2005
    • los angeles
    • Posts 513
    • Points 6,590

    Re: tearing fix - moncon off

    I am surprised that Avid has not chimed on this tearing issue.  I've tried serval things with no success, i'm always getting tearing.  I dislike hardware because it often creates minor sync delays (2 frames is too much for fast paced cutting).

     

    I've tried vertical sync, moncon, it different combinations to no avail.  What is the ideal refresh rate?  thanks

    w10, mc 2020.4, diy x299 7940x [view my complete system specs]
  • Fri, Jul 19 2013 2:41 PM In reply to

    • mjedit
    • Not Ranked
    • Joined on Mon, Feb 16 2009
    • Orkney
    • Posts 14
    • Points 180

    Re: tearing fix - moncon off

    I don't think refresh rate has anything to do with it. Interestingly, I've got two set ups now, both with LG monitors, both NVidia settings exactly the same (though they have different video cards and therefore drivers). My first set up, using moncon off, has no problems any more. The later set up has terrible tearing. The only solution here are 3 console commands: 'moncon off', 'fsp locked', 'tearingfix'. The first two have to be typed in at every reboot of Avid. The latter not. I have no full screen tearing until.... I fast forward or backwards. Don't ask me why. But the simple fix is to exit FSP and enter again. No tearing. Be interested to know if it works for you.

    There is so much written about this in the forums - I've spent days trying to find a true solution.

    These are the main threads I found useful:

    http://community.avid.com/forums/t/74412.aspx?PageIndex=1

    http://community.avid.com/forums/p/63436/412058.aspx#412058

    http://community.avid.com/forums/t/77967.aspx

    Doesn't seem to be any rationale at all. Afraid it's suck it and see. 

    If you want to know my exact NVidia settings let me know and I can email you screen grabs.

    MC 6.0.1, Windows 7 Professional 64 Bit, MB - ASUS P6T Intel X58 Express Chipset, Processor - Intel Core i7 i7-920 2.66 GHz Quad core, RAM - Corsair DDR3... [view my complete system specs]
    Filed under:
  • Thu, Feb 13 2014 7:07 PM In reply to

    • Marty
    • Top 150 Contributor
    • Joined on Sat, Dec 3 2005
    • Berlin, Germany
    • Posts 944
    • Points 11,060

    Re: tearing fix - moncon off

    I'm working with MC 7.03, now and I still have to use the console command "moncon off" to get fullscreen work. Will this ever be fixed? 

    all different setups in various editing suites. my own: MC 2018.2, OSX 10.12.6, iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 40GB RAM, Radeon... [view my complete system specs]

    www.film-editing.de

  • Sat, Dec 5 2015 9:56 PM In reply to

    • GaryF
    • Not Ranked
    • Joined on Mon, Jan 30 2012
    • Posts 78
    • Points 1,180

    Re: tearing fix - moncon off

    Its a sell hardware by Avid thing. Avid wants you to get one of there nitris boxes or something. Black magic can be used as well

     

     

  • Sun, Dec 6 2015 8:44 AM In reply to

    • Marty
    • Top 150 Contributor
    • Joined on Sat, Dec 3 2005
    • Berlin, Germany
    • Posts 944
    • Points 11,060

    Re: tearing fix - moncon off

    It's strange, when I don't use "moncon off" the fullscreen picture shows me the low contrast legal range colors on a computer screen, although "expand luminance range..." is enabled and I get tearing artefacts. 

    If I use "moncon off" the contrast is right but i can't play reverse, the software crashes more often, target masks are not working, i can't work with a reduced composer window. (MC 8.4.2)

    Really frustrating.

    all different setups in various editing suites. my own: MC 2018.2, OSX 10.12.6, iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 40GB RAM, Radeon... [view my complete system specs]

    www.film-editing.de

  • Mon, Dec 7 2015 5:01 AM In reply to

    • cls105
    • Top 500 Contributor
    • Joined on Thu, Oct 13 2005
    • los angeles
    • Posts 513
    • Points 6,590

    Re: tearing fix - moncon off

    windows 7 has tearing no matter what I did.

    windows 8.1 does not.  

     

    That's how i solved tearing.

    w10, mc 2020.4, diy x299 7940x [view my complete system specs]
  • Mon, Dec 7 2015 2:55 PM In reply to

    • DStone
    • Top 50 Contributor
    • Joined on Fri, Nov 4 2005
    • Massachusetts
    • Posts 3,774
    • Points 48,230
    • Moderator: Avid Media Composer for Liquid
      Moderator: MCA Mac
      Moderator: MCA PC
      Moderator: Media Composer Getting Started

    Re: tearing fix - moncon off

    I'm the one who posted the original MonCon Off work around, and as I said in that post it's a work around, not a fix. The original post was for getting around driver incompatibilties with unsupported Nvidia GTX cards and drivers, I never tested it with 3rd party hadrware I/O boxes.

    The only real solution is to get a supported Quadro (or AMD FirePro for the latest version). Other than that, I can tell you that for the GTX, driver 353.30 worsk with MC 8.4 and up on WIndows 8.1 Pro without a 3rd party I/O box. Depending on your system, you may have to upgrade or downgrade drivers, and there are some configurations that are incompatible in all cases.

    If you have a qualified video card, you should use the driver supplied with your version of MC (supplied in the MC directory) or one approved by Avid.

    DIY quad core I7-4790K, 32Gb, NVidia RTX 2060 Super 8, Win 10 Pro, MC (generally the latest or the one just before) [view my complete system specs]

    Dave S.

Page 1 of 2 (18 items) 1 2 Next >

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller